<?xml version="1.0"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="ca">
	<id>http://wiki.joanillo.org/index.php?action=history&amp;feed=atom&amp;title=Instal%C2%B7laci%C3%B3_Openbravo_2.50</id>
	<title>Instal·lació Openbravo 2.50 - Historial de revisió</title>
	<link rel="self" type="application/atom+xml" href="http://wiki.joanillo.org/index.php?action=history&amp;feed=atom&amp;title=Instal%C2%B7laci%C3%B3_Openbravo_2.50"/>
	<link rel="alternate" type="text/html" href="http://wiki.joanillo.org/index.php?title=Instal%C2%B7laci%C3%B3_Openbravo_2.50&amp;action=history"/>
	<updated>2026-09-23T04:01:36Z</updated>
	<subtitle>Historial de revisió per a aquesta pàgina del wiki</subtitle>
	<generator>MediaWiki 1.34.2</generator>
	<entry>
		<id>http://wiki.joanillo.org/index.php?title=Instal%C2%B7laci%C3%B3_Openbravo_2.50&amp;diff=257336&amp;oldid=prev</id>
		<title>Joan: Es crea la pàgina amb «*Manual d'usuari 2.50: http://wiki.openbravo.com/wiki/ERP/User_Manual *Technical Specifications 2.50: http://wiki.openbravo.com/wiki/ERP/Specifications *Functional Docume...».</title>
		<link rel="alternate" type="text/html" href="http://wiki.joanillo.org/index.php?title=Instal%C2%B7laci%C3%B3_Openbravo_2.50&amp;diff=257336&amp;oldid=prev"/>
		<updated>2018-05-30T18:16:35Z</updated>

		<summary type="html">&lt;p&gt;Es crea la pàgina amb «*Manual d&amp;#039;usuari 2.50: http://wiki.openbravo.com/wiki/ERP/User_Manual *Technical Specifications 2.50: http://wiki.openbravo.com/wiki/ERP/Specifications *Functional Docume...».&lt;/p&gt;
&lt;p&gt;&lt;b&gt;Pàgina nova&lt;/b&gt;&lt;/p&gt;&lt;div&gt;*Manual d'usuari 2.50: http://wiki.openbravo.com/wiki/ERP/User_Manual&lt;br /&gt;
*Technical Specifications 2.50: http://wiki.openbravo.com/wiki/ERP/Specifications&lt;br /&gt;
*Functional Documentation 2.50: http://wiki.openbravo.com/wiki/Functional_Documentation&lt;br /&gt;
*Business Intelligence Integration: http://wiki.openbravo.com/wiki/Business_Intelligence_Integration&lt;br /&gt;
&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
export ANT_HOME=/opt/apache-ant-1.8.0&lt;br /&gt;
export PATH=${PATH}:${ANT_HOME}/bin&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
(fer-ho per l'usuari joan i per l'usuari root)&lt;br /&gt;
&lt;br /&gt;
ficar aquestes variables a /etc/environment&lt;br /&gt;
&lt;br /&gt;
Descarrego OpenbravoERP-2.50MP13.tar.bz2. Descomprimeixo. Llegeixo el README&lt;br /&gt;
&lt;br /&gt;
Tinc instal.lats el Postgres, ant, Tomcat i un servidor Pentaho (opcional però vull avaluar aquesta opció).&lt;br /&gt;
&lt;br /&gt;
First, download the setup binary corresponding to your system:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ cd /home/joan/Descargas/OpenbravoERP-2.50MP13/&lt;br /&gt;
$ ant setup&lt;br /&gt;
Buildfile: /home/joan/Descargas/OpenbravoERP-2.50MP13/build.xml/manager/html&lt;br /&gt;
&lt;br /&gt;
setup.check.os:&lt;br /&gt;
&lt;br /&gt;
setup.check.arch:&lt;br /&gt;
&lt;br /&gt;
setup.exists.test:&lt;br /&gt;
&lt;br /&gt;
setup:&lt;br /&gt;
      [get] Getting: https://dev.openbravo.com/svn/packaging/setup/output/setup-properties-linux.bin&lt;br /&gt;
      [get] To: /home/joan/Descargas/OpenbravoERP-2.50MP13/config/setup-properties-linux.bin&lt;br /&gt;
      [get] ....................................................&lt;br /&gt;
      [get] ....................................................&lt;br /&gt;
      [get] ............................&lt;br /&gt;
&lt;br /&gt;
BUILD SUCCESSFUL&lt;br /&gt;
Total time: 11 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Next run the downloaded file in the config directory. For example in&lt;br /&gt;
x86 Linux:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ sudo bash (no cal)&lt;br /&gt;
$ cd config/&lt;br /&gt;
$ ./setup-properties-linux.bin (com a root) (no cal)&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
aquest fitxer és el binari d'instal.lació&lt;br /&gt;
&lt;br /&gt;
Selecciono Postgres:&lt;br /&gt;
*DB Name: openbravo&lt;br /&gt;
*admin: postgres/postgres&lt;br /&gt;
*DB Role: tad/tad&lt;br /&gt;
*Tomcat manager: http://localhost:8080/manager (admin/admin)&lt;br /&gt;
&lt;br /&gt;
El tema del Pentaho Server i la Authentication Class ho deixo de banda. Ho faré a posteriori seguint l'article:&lt;br /&gt;
*Business Intelligence Integration: http://wiki.openbravo.com/wiki/Business_Intelligence_Integration&lt;br /&gt;
&lt;br /&gt;
Comença la instal.lació, i acaba ràpidament sense cap missatge d'error, quan de fet hauria d'haver trigat una bona estona.&lt;br /&gt;
&lt;br /&gt;
$ tail -f /opt/OpenbravoERP/installation_logs/01database.log -&amp;gt; no exsteix. L'altra possibilitat és passar d'aquest bin i compilar.&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ ant install.source&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
It creates the database structure, builds the core, compiles&lt;br /&gt;
Openbravo and generates a war file. Comença a crear-se la base de dades.&lt;br /&gt;
&lt;br /&gt;
Deploy this war file into the tomcat/webapps directory. (/usr/share/tomcat6)&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
BUILD FAILED&lt;br /&gt;
SQL Command failed with: ERROR: no se pudo acceder al archivo «$libdir/uuid-ossp»: No existe el fichero ó directorio&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Trobo la solució a:&lt;br /&gt;
*http://forge.openbravo.com/plugins/espforum/view.php?group_id=100&amp;amp;forumid=650010&amp;amp;topicid=7006935&lt;br /&gt;
(No hi ha cap necessitat d'instal.lar com a root.)&lt;br /&gt;
&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ sudo apt-get install libuuid1 (ja ho tenia instal.lat)&lt;br /&gt;
$  sudo apt-get install postgresql-contrib&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Torno a compilar&lt;br /&gt;
&lt;br /&gt;
BUILD FAILED&lt;br /&gt;
&lt;br /&gt;
Les coses que han fallat són:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
...&lt;br /&gt;
compile.src.gen:&lt;br /&gt;
    [javac] /home/joan/OpenbravoERP-2.50MP13/src/build.xml:354: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds&lt;br /&gt;
...&lt;br /&gt;
[importsampledata] java.lang.OutOfMemoryError: Java heap space&lt;br /&gt;
...&lt;br /&gt;
Caused by: java.lang.OutOfMemoryError: Java heap space&lt;br /&gt;
...&lt;br /&gt;
Total time: 39 minutes 44 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&lt;br /&gt;
Prueba a darle mas memoria. In order to avoid HTTP Status 500 - java.lang.OutOfMemoryError: Java heap space, increase the value of -Xmx option in  Apache Tomcat CATALINA_OPTS variable. &lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
CATALINA_OPTS=&amp;quot;-server -Djava.awt.headless=true -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
JAVA_OPTS=&amp;quot;-Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
ANT_OPTS=&amp;quot; -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
&lt;br /&gt;
export CATALINA_OPTS=&amp;quot;-server -Djava.awt.headless=true -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
export JAVA_OPTS=&amp;quot;-Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
export ANT_OPTS=&amp;quot; -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&lt;br /&gt;
*a l'institut: torna a fallar, però arrenca http://localhost:8080/openbravo&lt;br /&gt;
* en el portàtil: (ho faig com a root, recordar que les variables _OPTS han d'estar establertes en aquest cas per al root)&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
BUILD SUCCESSFUL&lt;br /&gt;
Total time: 30 minutes 38 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
copy.files:&lt;br /&gt;
      [sql] Executing commands&lt;br /&gt;
      [sql] 2 of 2 SQL statements executed successfully&lt;br /&gt;
    [mkdir] Created dir: /usr/share/tomcat6/webapps/openbravo&lt;br /&gt;
     [copy] Copying 10105 files to /usr/share/tomcat6/webapps/openbravo&lt;br /&gt;
    [mkdir] Created dir: /usr/share/tomcat6/webapps/openbravo/WEB-INF/classes&lt;br /&gt;
     [copy] Copying 3287 files to /usr/share/tomcat6/webapps/openbravo/WEB-INF/classes&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
=Openbravo 2.50 a Ubuntu (amb paquet)=&lt;br /&gt;
*http://wiki.openbravo.com/wiki/Virtual_appliances#Community_Appliance&lt;br /&gt;
*http://wiki.openbravo.com/wiki/Virtual_appliances#Ubuntu_Installation&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
  Hardware&lt;br /&gt;
&lt;br /&gt;
    * In order to install Openbravo ERP 2.50 it is necessary to have at least 1024MB of RAM.&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
(no m'estranya que tingui problemes...)&lt;br /&gt;
&lt;br /&gt;
La manera més pràctica és insta.lar-ho a partir del paquet, tal com s'explica aquí.&lt;br /&gt;
&lt;br /&gt;
=Openbravo 2.50: Custom Installation=&lt;br /&gt;
*http://wiki.openbravo.com/wiki/Virtual_appliances#Custom_Installation&lt;br /&gt;
&lt;br /&gt;
Després de setup-properties-linux.bin, Configure the Openbravo.properties and log4j.lcf files using the configuration wizard.&lt;br /&gt;
&lt;br /&gt;
A Openbravo.properties puc escollir que es generi només el .war (es genera dins de lib), i més tard faré el deploy.&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
#Deploy mode: valid values [class, war, none]&lt;br /&gt;
#deploy.mode=class&lt;br /&gt;
deploy.mode=war &lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
El que fa el .bin és editar Openbravo.properties i log4j.lcf, que es poden editar manualment.&lt;br /&gt;
&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ ant install.source&lt;br /&gt;
&lt;br /&gt;
build.war:&lt;br /&gt;
      [war] Building war: /home/joan/Descargas/OpenbravoERP-2.50MP13/lib/openbravo.war&lt;br /&gt;
&lt;br /&gt;
BUILD SUCCESSFUL&lt;br /&gt;
Total time: 32 minutes 59 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
ant deploy.context (amb el Tomcat engegat...)&lt;br /&gt;
...&lt;br /&gt;
BUILD SUCCESSFUL&lt;br /&gt;
Total time: 1 minute 37 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
Before you access your Openbravo instance, it is strongly recommended that you run the following command to validate your system configuration:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
ant diagnostic&lt;br /&gt;
...&lt;br /&gt;
BUILD FAILED&lt;br /&gt;
/home/joan/Descargas/OpenbravoERP-2.50MP13/build.xml:787: The following error occurred while executing this line:&lt;br /&gt;
/home/joan/Descargas/OpenbravoERP-2.50MP13/src-diagnostics/build.xml:58: The following error occurred while executing this line:&lt;br /&gt;
/home/joan/Descargas/OpenbravoERP-2.50MP13/src-diagnostics/build.xml:115: The following error occurred while executing this line:&lt;br /&gt;
/home/joan/Descargas/OpenbravoERP-2.50MP13/src-diagnostics/build.xml:157: Server seems not to be Tomcat&lt;br /&gt;
&lt;br /&gt;
Total time: 37 seconds&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
El problema és del tomcat. A la línia 58 tinc:&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
    &amp;lt;antcall target=&amp;quot;check.tomcat&amp;quot; /&amp;gt;&lt;br /&gt;
&lt;br /&gt;
    &amp;lt;antcall target=&amp;quot;check.tomcat.version&amp;quot; /&amp;gt;&lt;br /&gt;
&lt;br /&gt;
  &amp;lt;target name=&amp;quot;check.tomcat.version&amp;quot;&amp;gt;&lt;br /&gt;
    &amp;lt;taskdef name=&amp;quot;checkTomcatVersion&amp;quot; classname=&amp;quot;org.openbravo.task.CheckTomcatVersion&amp;quot;&amp;gt;&lt;br /&gt;
      &amp;lt;classpath refid=&amp;quot;diagnostic.class.path&amp;quot; /&amp;gt;&lt;br /&gt;
    &amp;lt;/taskdef&amp;gt;&lt;br /&gt;
    &amp;lt;checkTomcatVersion /&amp;gt;&lt;br /&gt;
  &amp;lt;/target&amp;gt;&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&lt;br /&gt;
Miro el openbravo.log, i obtinc errors de tipus&lt;br /&gt;
PermGen space&lt;br /&gt;
&lt;br /&gt;
This error occurs when the JVM runs out of space in the permanent generation heap. Since the defaults for the JVM are quite low, the first step should be to increase the default using -XX:MaxPermSize.&lt;br /&gt;
&lt;br /&gt;
Minimal hardware requirement for Openbravo is 1GB RAM preferably 2Gb and Dual Core processor or equivalent 1.8Ghz, or higher.&lt;br /&gt;
Even if you achieve to run Openbravo on 256 RAM it will not going to serve sessions for other users, for that more than 2GB rather 4GB is needed.&lt;br /&gt;
&lt;br /&gt;
==Solució==&lt;br /&gt;
Amplio la memòria RAM a 2,5GB&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
CATALINA_OPTS=&amp;quot;-server -Djava.awt.headless=true -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
JAVA_OPTS=&amp;quot;-Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
ANT_OPTS=&amp;quot; -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
&lt;br /&gt;
export CATALINA_OPTS=&amp;quot;-server -Djava.awt.headless=true -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
export JAVA_OPTS=&amp;quot;-Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
export ANT_OPTS=&amp;quot; -Xms384M -Xmx1024M -XX:MaxPermSize=256M&amp;quot;&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
i també és important fer aquests canvis permanents.&lt;br /&gt;
&lt;br /&gt;
S'instal.la bé&lt;br /&gt;
&lt;br /&gt;
el fitxer openbravo.war que s'ha generat està en la carpeta /OpenbravoERP-2.50MP13/lib/&lt;br /&gt;
&lt;br /&gt;
Ara hem de desplegar el war. Copiem el war a la carpeta webapps/ del Tomcat, apaguem i arrenquem el Tomcat, i ja s'haurà desplegat.&lt;br /&gt;
&amp;lt;pre&amp;gt;&lt;br /&gt;
$ sudo cp openbravo.war /usr/share/tomcat6/webapps&lt;br /&gt;
$ sudo /usr/share/tomcat6/bin/shutdown.sh&lt;br /&gt;
$ sudo /usr/share/tomcat6/bin/startup.sh&lt;br /&gt;
&amp;lt;/pre&amp;gt;&lt;br /&gt;
&lt;br /&gt;
(Si no va, tornar a arrencar l'ordinador...)&lt;/div&gt;</summary>
		<author><name>Joan</name></author>
		
	</entry>
</feed>