Synfig Studio: Animació 2D

De wikijoan
Salta a la navegació Salta a la cerca

Contingut

Introducció[modifica]

La idea és fer animacions i videos 2D tal com es mostra en aquest video de Internet of things:

o com aquest (Españistán):

Una eina és Synfig Studio:

Instal.lació[modifica]

hi ha dos paquets per a Ubuntu: 32 i 64 bits:

  • synfigstudio_0.63.00_i386.deb
  • synfigstudio_0.63.00_amd64.deb
$ sudo dpkg -i synfigstudio_0.63.00-20110605.master.8_i386.deb

Scripts & Tools

  • Gimp2Synfig: A GIMP plugin for converting GIMP images to the SIF format by Il'dar Akhmetgaleev (AkhIL).

Utilitzar Synfig Studio. Comentaris sobre el manual[modifica]

Introduction[modifica]

Overview[modifica]

Diving In[modifica]

Getting Started[modifica]

Animation Basics[modifica]

Adding Layers[modifica]

Creating Shapes[modifica]

Amb Synfig Studio puc utilitzar la Wacom Intuos 12. S'ha d'anar a File → Input Devices... i seleccionar la Wacom Intuos 12x12 (screen), i aplicar. Abans, però, s'ha d'haver executat el script per configurar la Intuos, i ha d'estar connectat abans d'arrencar l'aplicació.

En el Draw Tool ha d'estar seleccionat el Press Width, i com s'explica:

Now grab your stylus, create a new file and click on the Draw Tool button in the toolbox. 
Set the default line width value to be big enough — say, 15pt — otherwise you will not 
notice any pressure sensitivity effect. Choose brown as the default fill color. 

És a dir, posar a 15pt el gruix de la línia.

El que és important és que efectivament la línia de contorn és sensible a la pressió (encara que això només es veu quan finalment es dibuixa la línia). Per tant, es poden aconseguir formes molt estètiques.

Aleshores, utilitzar la BLine Tool (línies de Beziers) és molt fàcil. Dibuixo i es van creant automàticament els punts-vèrtex. Si es creen molts punts hi ha dues maneres per tal de suavitzar i que n'hi hagi menys:

Draw tool is great for drawing complex shapes, but you end up with a bunch of ducks, which are hard to manipulate with the Transform Tool in the way we described above. There are two solutions here.

First, you can increase the "Smooth" value in the Tool Options Dialog while using Draw Tool. That will reduce the count of vertices produced at drawing time, but will make your shape less detailed.

Second, you can use Smooth Move Tool to deform an existing shape. Go for it and click the Smooth Move Tool button in the toolbox. The trick about this tool is that it affects selected ducks only. Press and hold your left mouse button in an empty place of the canvas. Drag to create a selection box. Release the mouse button when you are done. Or just hit CtrlA to select all ducks. Now you can deform the selected segments of BLines. You can change the size of the influence area by tweaking "Radius" in the Tool Options Pane

Animating Shapes[modifica]

L'exemple de l'animació de la flor (Flower Animations with Synfig) es pot veure al Youtube (són 4 videos). El primer:

Interface[modifica]

Quick Overview[modifica]

Interface[modifica]

Artwork Import[modifica]

GIMP Import[modifica]

SVG Import[modifica]

List Importer (Image sequence import)[modifica]

Artwork Construction[modifica]

BLine Tool[modifica]

Outline Layer[modifica]

Region Layer[modifica]

Color Editor[modifica]

Draw Tool[modifica]

Width Tool[modifica]

Paste Canvas Layer[modifica]

Children Lock[modifica]

Gradient Tool[modifica]

Gradient Editor[modifica]

Blend Method ???[modifica]

Masking[modifica]

Data Linking[modifica]

Linking[modifica]

Export[modifica]

Convert[modifica]

Sewing BLines[modifica]

Link to BLine[modifica]

ValueNodes[modifica]

Reusing Exported Value Nodes[modifica]

Switching Scenes[modifica]

Advanced ...[modifica]

Slideshows[modifica]

Duplicate Layer[modifica]

Brushes[modifica]

Animation[modifica]

Keyframe[modifica]

Time Track Panel[modifica]

Waypoint[modifica]

Reuse Animations[modifica]

Lock_Keyframes[modifica]

Onion Skin[modifica]

Following a BLine[modifica]

Z-Depth[modifica]

Time Loop Layer[modifica]

Rescale Animations[modifica]

Time_Offset_Parameter[modifica]

Animation Techniques[modifica]

Morphing[modifica]

Cut-out[modifica]

Output[modifica]

Preview[modifica]

Render_options[modifica]

Render Dialog[modifica]

SVG export[modifica]

Configuring Synfig[modifica]

Setup Dialog[modifica]

Unit System[modifica]

Image_Dimensions[modifica]

Canvas Properties[modifica]

Environment_Variables[modifica]

Appendix[modifica]

Synfig Studio vs Synfig[modifica]

Synfig CLI syntax[modifica]

Doc:Build Instructions[modifica]

How Do I...[modifica]

FAQ[modifica]

Window_Manager_Hints (merge to FAQ?)[modifica]

Keyboard Shortcuts[modifica]

Mouse_Shortcuts[modifica]

Examples[modifica]

Synfig Studio tips[modifica]

follow a Bline[modifica]

com es veu en el vídeo. es tracta de que un objecte (en l' exemple, un cap), segueixi la trajectòria definida per una BLine.

fer videos amb màxima resolució[modifica]

és un dels tips dels tutorials:

es tracta d'utilitzar el format yuv, i aleshores convertir-ho a avi amb ffmpeg.

$ ffmpeg -i animation.yuv -sameq animation.avi

Veure també un post del fòrum:

I've used the following format with good results directly from Synfig Studio:
Target: ffmpeg
extension: .avi
codec:mpeg4
bitrate:1500
resolution: 1280x720
quality:1 (best)
antialiasing: 3 or 4 (higher doesn't produce visible effects at that size)

Example: http://www.youtube.com/watch?v=4akilsBsxps

renderitzar[modifica]

Compte en renderitzar: (es pot renderitzar en línia de comandes)

maxdav, did you used synfigstudio to render the animation? There is a known bug that would produce glitches in the render if you continue working with synfigstudio meanwhile it is rendering. For long render it is recommended to use synfig command line instead, until this bug is solved.

Synfigstudio is the GUI and Synfig is the renderer. Well really synfigstudio lies on libsynfig that is part of synfig package. Just open a terminal and type: synfig it would complain about not having any parameter.

Here more help: http://synfig.org/Synfig_Core_options

fer núvols[modifica]

fer Multiplane Camera (efecte professional)[modifica]

programació: el tir parabòlic[modifica]

Amb Synfig Studio es pot modelitzar lleis físiques per tal que els moviments siguin reals.

the walk cycle[modifica]

fer fum (particles)[modifica]

Com fer fum:


First of all, please read the particles wiki page: http://synfig.org/wiki/Particles_V2.0
Maybe just read it can solve most of the questions.
To produce a smoke, you have to change the particle internal (the changing circle frmo red to yellow in the template) to a feathred region that deforms along the time to give it more randomness. Then you have to set the following parameters:
Velocity: some value.
Gravity some value
Beta: horizontal to the right (to where the winds go)
Damping forces: start with a small value and increase it to see its effect.
Size X: some wide value
Size Y: Some narrow value
Position X and Y: where you want to place the source of the smoke
Angle Spread: give it a narrow value
Angle: 90 degrees.
and leave the rest as it is.

looping background[modifica]

en el fòrum es va proposar un challenge:

es tracta de poder fer alguna cosa com:

en aquest cas a més hi ha un multipla i això afegeix perspectiva.

D'aquest es disposa del codi font:

Treballo sobre aquest exemple de l'arbre (http://www.youtube.com/watch?v=srB8r7tDNoI)

Elimino les capes que representen els reflexes i efecte de perspectiva. El projecte són 18 seg, i allò important és veure que hi ha un Time Loop de 6 seg, i que per tant es repeteix tres vegades.

Recordem que si no sé on és la finestra de Paràmetres puc fer Arxiu > Taulers (Canvas) > Restablir Finestres.

Per a fer un Time Loop: Capa > Nova Capa > Other > Time Loop

Passos bàsics per a fer un looping background:

  1. pensar el projecte. Escollir les dimensions del projecte i les dimensions de la muntanya de manera que quan es faci loop es vegi la continuïtat
  2. editar el que dura el projecte. Per exemple, 15 seg, que seran 3 bucles de 5 seg
  3. amb una BLine fer unes muntanyes
  4. fer moure aquest paisatge (5s) (no he d'utilitzar per res fotogrames clau). Ficar el projecte en mode Edició d'Animació
  5. la part que trobo més complicada és editar la línia de temps. Una manera és ficar el frame on vull anar, per ex 5s (i Enter, i veig com la línia de temps se'm mou). I aleshores moure la capa allà on la vull ficar... i és aleshores que apareix la rodoneta en la línia de temps (la rodoneta, si l'edito amb botó dret, puc escollir el mètode d'interpolació, i aleshores segons el mètode ja no és una rodoneta).
  6. ara ja puc fer moure la part que tinc (de 0 a 5seg)
  7. ara he de fer tres bucles. Capa > Nova Capa > Other > Time Loop. La capa s'ha de situar a sobre de l'anterior. Local Time=5s; Duration=5s· I ja esta, les dues capes (Time Loop i BLine) les puc encapsular).

Per importar una imatge al projecte com una capa ho trobo difícil. Fent-ho com a Arxiu > Importa se'm carrega la imatge i no sé com escalar-la. Una altra possibilitat és Capa > Nova Capa > Other > Import, i en les propietats d'aquesta imatge ficar la ruta de la imatge que vull carregar. D'aquesta manera sí que és fàcil escalar la imatge.

Projecte: aterratge avió[modifica]

La idea és que tenim un background (muntanyes, paisatge, núvols) que es va movent i un avió que està quiet. Per ser més realistes, l'avió pot pujar i baixar lleugerament sobre la seva posició, i fins i tot avançar-se o retrassar-se sobre la seva posició. Això es fa amb l'exemple en què un cos segueix una BLine,

La primera idea és fer un background que es vagi movent amb un Time Loop. Ara bé, si volem que l'avió aterri, no pot ser de cop i volta el background s'aturi. Per tant, el background s'hauria d'anar desaccelerant fins a aturar-se, i això significa ficar una equació linial per a la velocitat amb què es mou el background fins a aturar-se. Per tal de modelitzar amb equacions matemàtiques, mirar l'exemple del tir parabòl.ic (http://synfig.org/wiki/Parabolic_Shot). Entenent l'exemple del tir parabòl.lic s'ha de poder aconseguir que l'avió aterri amb suavitat. Llegir bé el tutorial... si s'entén bé, és realment potent... mirar per exemple el diagrama de com varia el offset amb el temps... en mode edició de video, puc definir el valor dels diferents paràmetres amb el temps.

Ara bé, si no ho vull fer amb una fórmula, puc fer un background molt i molt llarg, i definir una sèrie de trams. A cada tram la velocitat es va reduïnt fins a zero.

playmobil 3d object for blender[modifica]

pregunta en el forum de Synfig (13/1/2013):

This topic is not exactly related with synfig, but I think is the right place to ask. I'm planning to make a play mobile stop motion film with my children. Searching youtube I saw films like this one:

http://www.youtube.com/watch?v=9a6bm2ucdWc

and this is not stop motion, isn't it? How can I make a similar one, what software (Linux) can I use. Is synfig useful for make a similar film? How can I achiveve this precision of movement and animation?

respostes

	
I don't think the video you linked is made with the stop motion technique, pal. It's a 3D animation probably made with programs like 3Ds Max, Maya, Blender or similars.
However, if you want to work with stop motion there are specific programs too. Try Stop Motion Pro or Dragonframe. I hope this will help you. :)

the film was done in 3d rendering/modeling / https://www.youtube.com/watch?v=HbkjgMZ-6zs

if you choose to do your film in 3d, you can try blender .

playmobil 3d object for blender

La idea és que hi ha una llibreria a Blender per fer pel.lículues amb els personatges de Playmobil:



creat per Joan Quintana Compte, juny 2011