LibreCAD

De Wikijoan
Dreceres ràpides: navegació, cerca

Contingut

Instal.lació (versió 1.0.1)

$ apt-get install librecad

A 10.04 he tingut problemes de dependències i s'han resolt instal.lant directament els paquests deb.

Instal.lació des de les fonts (versió 2)

previ a fer la instal.lació hi ha preparar el sistema per a ser un bon entorn de desenvolupament: g++, qt4,...

$ sudo apt-get install g++ gcc make git-core libqt4-dev qt4-qmake libqt4-help qt4-dev-tools libboost-all-dev libmuparser-dev libfreetype6-dev
 libmuparser-dev libfreetype6-dev

Alguns dels paquets ja els tinc, però d'altres no.

$ cd ~
$ mkdir LibreCADsource
$ cd LibreCADsource
$ git clone https://github.com/LibreCAD/LibreCAD.git

$ cd LibreCAD
$ qmake librecad.pro
$ make

i dóna un error de compilació amb el paquet libmuparser-dev. Se soluciona de la següent manera:

Change
#include <muParser.h>
to
#include "/usr/include/muParser/muParser.h"
in the file librecad/src/lib/math/rs_math.cpp 

i ara sí que compila.

Ja podem executar la versió 2:

$ cd unix
$ ./librecad

Gener 2014: problemes amb l'opció -std=c++11

Al compilar tinc problemes amb l'opció:

-std=c++11

GCC versions prior to 4.7 use "-std=c++0x" instead of "-std=c++11" since the standard wasn't definitely C++11 at the time those versions were released.

LibreCAD requires a C++11-capable compiler to build, és a dir, la versió 4.7. Però en els repositoris del 12.04 hi ha la 4.6

$ gcc -v
gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)

manera de procedir:

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install gcc-4.7-base
$ sudo apt-get install gccgo-4.7

I ara he de fer que la versió 4.7 sigui la versió per defecte:

$ sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7

$ sudo update-alternatives --config gcc
Hi ha 2 possibilitats per a l'alternativa gcc (que proveeix /usr/bin/gcc).

  Selecció    Camí             Prioritat  Estat
------------------------------------------------------------
* 0            /usr/bin/gcc-4.6   60        mode automàtic
  1            /usr/bin/gcc-4.6   60        mode manual
  2            /usr/bin/gcc-4.7   40        mode manual

Premeu retorn per a mantenir l'opció per defecte[*], o introduïu un número de selecció: 2                       

$ gcc -v
...
gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-0ubuntu3)

Però g++ ha desaparegut i l'he hagut de reinstal.lar El mateix que acabo de fer per a gcc ho hauré de fer per a g++:

$ g++ -v
...
gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)

Finalment segueixo

per tal d'instal.lar g++ v 4.7 (i gcc v4.7). S'ha d'instal.lar una PPA

$ gcc --version
gcc (Ubuntu/Linaro 4.7.3-2ubuntu1~12.04) 4.7.3

$ g++ --version
g++ (Ubuntu/Linaro 4.7.3-2ubuntu1~12.04) 4.7.3

Finalment compila i l'executable es troba dins la carpeta unix/

Instal.lació Ubuntu 16.04

$ sudo apt-get install librecad

Tutorials

Com a unitat per defecte agafo els mm. Em preocupa el fet de què les dimensions que pinti per la pantalla siguin les que realment em sortiran per la impressora.

Faig un cercle de 10cm. Vaig a imprimir-lo.

File > Print preview > fixar-se en què la proporció sigui 1:1

Imprimim, i efectivament el cercle té diàmetre de 10cm.

video Tutorial:

És interessant posar les cotes del que es dibuixa. crear una capa per a cotes

Treballar amb blocs

Això és el que moltes vegades es necessita. Si es dissenya un cargol, i aquest cargol es vol copiar vàries vegades, s'ha de fer amb blocs. L'avantatge dels blocs respecte copiar i moure és que estan linkats. Si modifico un bloc automàticament quedat modificats els altres blocs.

No m'ha sigut fàcil fer blocs perquè no és massa intuïtiu, s'ha d'entendre el truquet d'apretar Enter i que canvïi la forma de la creueta.

Però sobretot allò important dels blocs és que funcionen com una llibreria, es poden importar a d'altres dissenys. Per ex, per al slingshot creo un bloc només dels forats que s'hauran de practicar a la fusta del tabletop. Aleshores en el tabletop puc importar aquest bloc, i ja puc inserir els dos slingshots (un d'ells fent el mirror).

Fer mirror i altres modificacions

Per fer un mirror (i altres operacions) no és gens intuïtiu. Primer seleccionem totes les entitats que volem, aleshores Modify->Mirror, i aleshores important apretar Enter i veiem que la creueta canvia, i en la línia de comanda posa 'Specify first point of mirror line'. Això és important doncs hem de saber sobre quin punt rota.

De fet la idea de moure/copiar és la mateixa.

I amb aquesta idea de que apreto Enter i canvia la creu ja puc fer els blocs, doncs la creueta és el punt de referència on es crearà el bloc.

Exportar al GIMP

És necessari exportar els fitxers de CAD al GIMP per tal de ficar el artwork. I és important mantenir les dimensions. Per ex, en el cas del slingshot, visualitzo només allò que interessa, el contorn. El LibreCAD, amb l'opció exportar, el que fa és retallar un requadre de la part que és visible, i jo li he de dir les dimensions que té aquest requadre. Exporta a png. Aleshores, amb el GIMP obro la imatge, que bàsicament és un contorn negre sobre fons blanc. El que puc fer ara és seleccionar només el contorn negre, i copio la selecció i la obro en una altra imatge com una nova capa. Aleshores ja puc ficar a sobre el artwork, que a l'imprimir sabré per on he de retallar.

keywords

Polilines

No és el mateix 3 línies connectades (que són 3 entitats), que una polilínia de 3 segments (que és una entitat).

En la versió 2.0.9 hi ha l'opció Draw > Poliline > Create Polyline from different segments. Aquesta opció no hi és en la versió 1.0.1.

La gràcia de la polyline a més és que puc ajuntar segments amb arcs. La manera de com construir-ho crec que no es pot fer, però el que sí que es pot fer és si tenim un segment i un arc (per ex, una pista d'atletisme), aleshores podem crear-ne una polilínia.

A CNC és millor tenir polilínies que segments individuals, perquè la tool path a realitzar serà més evident.

Splines

És molt interessant l'opció d'importar una imatge en una capa, i traçar amb splines la sil.lueta d'aquesta imatge. De totes maneres, si pensem en CNC i mecanització, el cost en temps de fer splines és molt gran, genera molt G-Code. Per tant, sempre que es pugui, que les rectes siguin rectes, i que els arcs siguin arcs.

Especificar la longitud d'una línia

La idea és utilitzar el símbol @ per indicar que utilitzo coordenades relatives:

0, main menu: Edit->Current Drawing Preferences->Units, set main drawing units to mm ;
1, main menu: Draw->Lines->2 points , to start line drawing;
2, choose the start point; Please notice the relative zero is moved to the start point
3, when prompted to choose the next point, use spacebar or mouse clicking to activate the command line;
4, type in @1.25<25 in the command line, press enter to accept and draw the line; @ means coordinates is relative (the the current relative zero). You can use cartesan coordinate such as "@1.25*cos(25*pi/180), 1.25*sin(25*pi/180)"
5, right click to stop the line drawing action.

Això també serviria per fer el Move d'una figura.


creat per Joan Quintana Compte, juny 2013, novembre 2016

Eines de l'usuari
Espais de noms
Variants
Accions
Navegació
IES Jaume Balmes
Màquines recreatives
CNC
Informàtica musical
joanillo.org Planet
Eines