Instal.lació Mediawiki

De Wikijoan
Dreceres ràpides: navegació, cerca

Contingut

Instal.lació

Si no tenim el mysql instal.lat, amb el Synaptic instal.l mysql-server i tot el que li depèn. En el procés d'instal.lació em demana un pwd per a root: root/xxxx

per connectar-me al mysql en el mode més bàsic:

$ mysql -uroot -pxxxx

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema | 
| mysql              | 
+--------------------+
2 rows in set (0.00 sec)

aquestes dues bases de dades són les que hi ha per defecte

De SourceForge em baixo mediawiki-1.9.3.tar.gz (que ja la vaig instal.lar al Linkat)

i ho desempaqueto. Se'm crea la carpeta mediawiki-1.9.3 i la moc a la carpeta wiki:

$ tar xvzf mediawiki-1.9.3.tar.gz
$ mv mediawiki-1.9.3 wiki

Ara he de fer un site Apache que es digui wiki:

$ joe /etc/apache2/sites-available/default

   Alias /wiki "/home/joan/wiki/"
    <Directory "/home/joan/wiki/">
        Options Indexes MultiViews FollowSymLinks   
        AllowOverride all
        Order deny,allow 
        #Deny from all                              
        #Allow from 127.0.0.0/255.0.0.0 ::1/128
        Allow from all
    </Directory>

i creo el fitxer .htaccess per protegir el site amb login i password

$ cat .htaccess
AuthUserFile /home/joan/.htpasswd
AuthName "Aplicació Socrathos"
AuthType Basic
Require user joan

Reinicio el Apache:

$ /etc/init.d/apache2 restart

i ja funciona:

http://localhost/wiki/

Ara s'ha de configurar, però hi ha un problema de permisos d'escriptura:

$ cd /home/joan/wiki
$ chmod a+w config

Configuració:

Wiki name: wiki
Admin username: joan/xxxx
deshabilito totes les opcions de mail

Em deixa escollir entre mysql i postgres. Escullo mysql per compatibilitat amb el mysql de l'institut (possible exportació...)

Database host: localhost
Database name: wikidb

database username: joan/xxxx -> es crearà en el moment de la instal.lació, perquè especifico el superuser account (root/xxxx)
charset: Backwards-compatible UTF-8

Installation successful! 

Move the config/LocalSettings.php file into the parent directory, then follow this link to your wiki.
$ mv config/LocalSettings.php .

i ja funciona!

Extensions

ToogleDisplay: text ocult

Ho utilitzo per que si publico les solucions dels exercicis, que no es mostrin de bones a primeres, sinó només que es vegin si l'alumne clica sobre Show Details.

Ficar en el fitxer LocalSettings.php:

require_once( "extensions/ToggleDisplay/ToggleDisplay.php" );

i el codi de ToggleDisplay.php està en l'enllaç. Amb el tag <toggledisplay> es pot ocultar/mostrar el text. Reiniciar el navegador i/o reiniciar Apache.

Instal.lació octubre 2011 (nou servidor)

Parteixo d'una còpia de la wiki amb versió 1.9, i ara la versió actual és la 1.17. El problema és que l'estructura de la base de dades no és la mateixa, s'ha de fer un upgrades de la base de dades (amb un script que es proporciona).

Em descarrego la versió 1.17

La instal.lo sobre la bd wikidb117. Faig una instal.lació, i després ja em preocuparé de fer un upgrade.

Quan em demana database settings, fico InnoDb i UTF-8

scp joan@192.168.1.130:/mnt/disc_windows/copia_wikidb111011.sql /home/joan

mysql -u root -p wikidb117 < /home/joan/copia_wikidb111011.sql

he ficat una base de dades de la versió 1.9 dins una bd de la versió 1.17. Ara he de fer el upgrade

llegir el fitxer UPGRADE

From the command line, browse to the "maintenance" directory and run the
update.php script to check and update the schema. This will insert missing
tables, update existing tables, and move data around as needed. In most cases,
this is successful and nothing further needs to be done.


Certain scripts will require elevated access to the database. In order to
provide this, first create a MySQL user with "all" permissions on the wiki
database, and then set $wgDBadminuser and $wgDBadminpassword in your
LocalSettings.php

$wgDBadminuser="root";
$wgDBadminpassword="****";

El script update.php. S'ha d'executar des de la línia de comandes:

$ php update.php
...
Creating page_restrictions table...ok
Migrating old restrictions to new table...
...

El upgrade ha funcionat correctament. Ara s'ha de fer la pila de coses per tal que la funcionalitat sigui la mateixa, i sobretot mirar temes de seguretat per tal de què no es faci spam sobre la bd.

fitxer LocalSettings.php

# The following permissions were set based on your choice in the installer
$wgGroupPermissions['*']['createaccount'] = false;
$wgGroupPermissions['*']['edit'] = false;
$wgGroupPermissions['*']['read'] = true; 

La última línia la tenia a false i no es podia llegir la wiki si no et logues (massa restrictiu)

Per tal de què la cache no faci males jugades:

# canvis octubre 2011
$wgEnableParserCache = false;
$wgCachePages = false;
$wgExternalLinkTarget = '_blank';

amb $wgExternalLinkTarget = '_blank'; el que s'aconsegueix és que els enllaços externs s'obrin en una nova pàgina.

Canviar el password de l'usuari Joan

$ cd maintenance
$ ls changePassword.php
$ php changePassword.php --user=Joan --password=*

creat per Joan Quintana Compte, juny 2008

Eines de l'usuari
Espais de noms
Variants
Accions
Navegació
IES Jaume Balmes
Màquines recreatives
CNC
Informàtica musical
joanillo.org Planet
Eines