Edirol FA-66 amb Ubuntu Studio

De Wikijoan
Dreceres ràpides: navegació, cerca

La targeta de so Edirol FA-66, de Roland, és un dispositiu extern que es connecta per firewire. Jo no he aconseguit fer-lo funcionar sota Linux, i com a conclusió, he adquirit una Edirol UA-25 EX, que és midi.

Nota posterior: no va funcionar el setembre 2008 perque el xipset del firewire ha de ser Texas Instrumens (TX).

http://ubuntuforums.org/showthread.php?t=740445

d'entrada, només veig una targeta de so:

$ cat /proc/asound/cards
 0 [ICH6           ]: ICH4 - Intel ICH6
                      Intel ICH6 with STAC9752,53 at irq 16

Informació de FireWire a Ubuntu: https://help.ubuntu.com/community/Firewire

la utilitat modprobe és per carregar un mòdul:

$ sudo modprobe dv1394

http://www.hispasonic.com/comunidad/audio-firewire-audiophile-ubuntu-con-jackd-freebob-t169902.html

$ sudo apt-get  install libfreebob0 -> això ja està fet en la versió més actual
$ sudo modprobe ieee1394
$ sudo modprobe raw1394


http://www.ffado.org/

la informació de ffado.org diu que: Edirol FA-66 Supported

llegir la FAQ, i també la FAQ de http://freebob.sourceforge.net/index.php/FAQ

el projecte freebob ha passat a ser el projecte ffado

jackd -R -d freebob -> cannot load driver module freebob

$ sudo apt-get  install libfreebob0-dev

no arregla res

lsmod -> llista els mòduls carregats

per treure un mòdul del kernel s'utilitza rmmod

cannot load driver module freebob. No tinc instal.lat el driver, l'instal.lo a pèl (tot i que de fet els paquets sí que els tenia instal.lats).

La guia que he fet servir per a instal.lar el driver freebob és

http://sourceforge.net/project/showfiles.php?group_id=117802

[tanmateix, he trobat una altra guia específica per a Debian: http://freebob.sourceforge.net/index.php/FreeBoB_on_Debian_GNU/Linux]

baixo el driver libfreebob-1.0.11.tar.gz

Segueixo el README, que té instruccions per compilar

libraw1394  (>= 1.2.1),  http://www.linux1394.org
libiec61883 (>= 1.1.0),  http://www.linux1394.org
libavc1394  (>= 0.5.3),  http://sourceforge.net/projects/libavc1394

aquestes tres llibreries, i en aquest ordre, les instal.lo a /usr/local/lib fent:

$ sudo ./configure
$ sudo make
$ sudo make install

(s'ha de fer 3 vegades, i s'instal.la sense problemes)

$ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
$ export LD_LIBRARY_PATH=/usr/local/lib

$ sudo cp libfreebob-1.0.11.tar.gz /usr/local/lib

$ sudo tar -xvzf libfreebob-1.0.11.tar.gz 
$ cd libfreebob-1.0.11/

$ sudo ./configure -> no funciona, s'han d'instal.lar uns quants paquets

no troba el paquet ALSA, i no pot continuar -> agafo la llibreria de http://www.alsa-project.org/main/index.php/Main_Page, i la instal.lo com lo anterior (de fet, la llibreria alsa era un prerequisit, segons diu el README)

$ tar -jvxf  alsa-lib-1.0.17a.tar.bz2

ja està solucionat, ja he instal.lat la llibreria alsa

$ sudo make
dóna un error, i en comptes faig
$sudo make check
$ sudo make install

després de fer tot això, faig

$ jackd -R -d freebob

-> cannot load driver module freebob (dóna el mateix error que tenia) Tanmateix, reinicio, i ara em diu

$ jackd -R -d freebob ->
loading driver ..
Freebob using Firewire port 0, node -1

(per tant, s'ha instal.lat bé el driver) però em dóna algun error relacionat amb la freqüència de mostreig

IsoStreamInput plug 0 does not support sample rate 48000
FreeBoB ERR: FREEBOB: Error creating virtual device

i per tant no pot crear el dispositiu virutal.


Jugant amb el Jack Control ho he aconseguit

he probat amb la interfície hw:0, i la comanda que l'ha fet funcionar és:

jackd -dfreebob -dhw:0 -r44100 -p1024 -n3 -D

-> funciona


a vegades em dóna l'error `default' server already active és com si ja hi hagués algun servidor jack funcionant.

$ ps axuw|grep jack

tanmateix, mato el procés i continua passant el mateix

llegeixo aquest fòrum: http://ph.ubuntuforums.com/showthread.php?t=897236

$ sudo gedit /etc/udev/rules.d/40-permissions.rules

ho deixem així:

KERNEL=="raw1394",                      GROUP="audio"
KERNEL=="dv1394*",                      GROUP="audio"
KERNEL=="video1394*",                   GROUP="video"
$ killall jackd



he reiniciat la màquina sense el FA-66, i quan faig

jackd -dfreebob -dhw:0 -r44100 -p1024 -n3 -D

em dóna error (lògic). El tema és veure que es carrega bé el driver freebob, però que peta perquè no troba cap dispositiu.

El driver no es carrega, i et diu: estan ben instal.lats els mòduls ieee1394 i raw1394?

Faig lsmod i veig que el raw1394 no està instal.lat (ahir el vaig instal.lar, potser els canvis no són permanents...)

Torno a fer

$ sudo modprobe raw1394

i ja queda instal.lat el mòdul.


Nota: per tal que els canvis siguin permanents, llegir

http://freebob.sourceforge.net/index.php/FreeBoB_on_Debian_GNU/Linux

If you will often (or always) need access to the raw1394 driver, load the module at bootup:

   # modconf
If that command did not work (resulting in output of 'modconf: command not found'), then install modconf first:
   # apt-get install modconf
   # modconf

look for the line: kernel/drivers/ieee1394

Press enter to select this submenu and then install raw1394. The module will now be loaded immediately and will also be loaded each time the machine boots.


Faig

$ jackd -dfreebob -dhw:0 -r44100 -p1024 -n3 -D

(si fico l'opció -v, de verbose, em dóna informació)

i ara ja dóna un altre error, que deu ser perquè no troba el dispositiu en el bus firewire.

Arrenco el jack amb el driver alsa, i ara veig que no em deixa arrencar amb default, però puc arrencar amb el hw0. Compte perquè aquesta interfície és la que es correspon al FA-66 quan està connectat. Suposo que quan està connectat la targeta de so interna passa a ser la hw1 (comprovar, veig després que no és així)

$ jackd -dalsa -dhw:0 -r44100 -p1024 -n3

-> funciona (tant si no està connectat el FA-66 com si sí que ho està)


http://freebob.sourceforge.net/index.php/List_of_Supported_Devices

Devices with BeBoB firmware (suportat):
Edirol	FA-66	FireWire Audio Capture Interfac

In order for ordinary users to be able to use the 1394 related device drivers, such as raw1394, one needs to make sure that the permissions of these devices are correct. On modern systems, this is done by changing the configuration of udev.

$ grep -R 1394 /etc/udev/ | grep rules


Freebob using (interessant)

http://freebob.sourceforge.net/index.php/Using

ja tinc instal.lat el freebob i puc engegar el jack amb el freebob, però encara no he aconseguit escoltar res per la FA-66

$ jackd -R -P60 -p128 -dfreebob -dhw:0 -r44100 -p128 -n3 -D

...uhu, should be ok. Don't worry about Warnings. -> ok

So, use a player directioning to jack, e.g. mplayer. And don't forget: run as same jackd user.

$ sudo apt-get install mplayer
$ mplayer -ao jack cow.wav

(or mp3, or, well, you know!) Listening? Of course :) If not, it can be for several reasons. This is extremely complicated. First thing's first, check UdevConfiguration (http://freebob.sourceforge.net/index.php/UdevConfiguration). If this doesn't do it, you are going to have to look around and try to find someone to help. At this stage in development, there are often errors in the implementation of so many different possible places that the freebob developers are hard pressed to assist each interested individual in trying to correct problems. Review our FAQ for more possible solutions.

L'error que em dóna és

Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

UdevConfiguration (http://freebob.sourceforge.net/index.php/UdevConfiguration)

In order for ordinary users to be able to use the 1394 related device drivers, such as raw1394, one needs to make sure that the permissions of these devices are correct. On modern systems, this is done by changing the configuration of udev. $ grep -R 1394 /etc/udev/ | grep rules

Edirol Fa-66 in Gutsy: funny behavior

http://ubuntuforums.org/showthread.php?t=714020

https://help.ubuntu.com/community/UbuntuStudioPreparation -> preparació de Ubuntu Studio des de Ubuntu


El primer objectiu seria reproduir un wav amb el servidor jack i el driver alsa Engego el servidor:

$ jackd -dalsa -dhw:0 -r44100 -p1024 -n3

intento reproduir el fitxer cow.wav amb el mplayer:

could not open/initialize audio device -> no sound

amb el Audacity Sound Editor:

Error al abrir el dispositivo de sonido

$ mplayer -ao alsa cow.wav -> sí que funciona, però el jack ha d'estar aturat!!

i amb el mode gràfic (configurant preferences d'audio a alsa), també funciona

el mplayer, en mode gràfic, es poden editar les preferències d'audio. Escollim el driver alsa, i podem configurar el driver. Podem escollir entre:

hw=0.0 (funciona), hw=0.1 (no funciona) i hw=0.2 (no funciona)

creat per Joan Quintana Compte, octubre 2008

Eines de l'usuari
Espais de noms
Variants
Accions
Navegació
Institut Jaume Balmes
Màquines recreatives
CNC
Informàtica musical
joanillo.org Planet
Eines